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Can't install Astro using a personal email account

You might experience errors if you try to install Apache Airflow on Astro from the Microsoft Azure Marketplace by using a personal email account. This article explains why the errors occur and how to resolve them.

Prerequisites

  • Access to the Azure portal
  • An email address that's associated with a unique ___domain (such as work or school)
  • Subscription owner permissions in Azure

Symptoms

If you try to install Apache Airflow on Astro by using a personal email account (for example, Outlook, Gmail, or Yahoo), the installation fails. Additionally, you receive an error or warning message that states that the email ___domain is unsupported.

Cause

Astro installation from the Azure Marketplace doesn't support personal email accounts from generic domains. The service requires an email address that has a unique ___domain that's typically associated with an organization, school, or business.

Solution

To resolve this problem, follow these steps:

  1. Use an email address that has a unique ___domain (for example, your organization's email ___domain).
  2. Create a new user in Azure that has a unique ___domain, and assign subscription owner permissions to that user.
  3. Retry the Astro installation from the Azure Marketplace.

Third-party contact disclaimer

Microsoft provides third-party contact information to help you find additional information about this topic. This contact information may change without notice. Microsoft does not guarantee the accuracy of third-party contact information.